import re
regex = re.compile(r"^\s*\K(?:^.*\S.*\r?\n)*?^.*[ ]चैव[ ]यत्[ ].*(?:\r?\n^.*\S.*)*", flags=re.MULTILINE)
test_str = ("सत्कारमानपूजार्थं तपो दम्भेन चैव यत् ।\n"
"क्रियते तदिह प्रोक्तं राजसं चलमध्रुवम् ॥ 17.18॥\n\n"
"दृष्ट्वा तु पाण्डवानीकं व्यूढं दुर्योधनस्तदा ।\n"
"आचार्यमुपसङ्गम्य राजा वचनमब्रवीत् ॥ १-२॥\n\n"
"पश्यैतां पाण्डुपुत्राणामाचार्य महतीं चमूम् ।\n"
"व्यूढां द्रुपदपुत्रेण तव शिष्येण धीमता ॥ १-३॥\n\n"
"अन्ये च बहवः शूरा मदर्थे त्यक्तजीविताः ।\n"
"नानाशस्त्रप्रहरणाः सर्वे युद्धविशारदाः ॥ १-९॥\n\n"
"अपर्याप्तं तदस्माकं बलं भीष्माभिरक्षितम् ।\n"
"पर्याप्तं त्विदमेतेषां बलं भीमाभिरक्षितम् ॥ १-१०॥\n\n\n"
"सत्कारमानपूजार्थं तपो दम्भेन चैव यत् ।\n"
"क्रियते तदिह प्रोक्तं राजसं चलमध्रुवम् ॥ 17.18॥\n"
"hello world\n\n"
" kk\n"
"kubhpkn\n"
"अभिसन्धाय तु फलं दम्भार्थमपि चैव यत् ।\n"
"इज्यते भरतश्रेष्ठ तं यज्ञं विद्धि राजसम् ॥ 17.12॥\n\n"
"अयनेषु च सर्वेषु यथाभागमवस्थिताः ।\n"
"भीष्ममेवाभिरक्षन्तु भवन्तः सर्व एव हि ॥ १-११॥\n\n"
" सत्कारमानपूजार्थं तपो दम्भेन चैव यत् ।\n"
" क्रियते तदिह प्रोक्तं राजसं चलमध्रुवम् ॥ 17.18॥\n\n"
"सत्कारमानपूजार्थं तपो दम्भेन चैव यत् ।\n"
"क्रियते तदिह प्रोक्तं राजसं चलमध्रुवम् ॥ 17.18॥")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")