import Foundation
let pattern = #"^\s*\K(?:^.*\S.*\r?\n)*?^.*[ ]चैव[ ]यत्[ ].*(?:\r?\n^.*\S.*)*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
सत्कारमानपूजार्थं तपो दम्भेन चैव यत् ।
क्रियते तदिह प्रोक्तं राजसं चलमध्रुवम् ॥ 17.18॥
दृष्ट्वा तु पाण्डवानीकं व्यूढं दुर्योधनस्तदा ।
आचार्यमुपसङ्गम्य राजा वचनमब्रवीत् ॥ १-२॥
पश्यैतां पाण्डुपुत्राणामाचार्य महतीं चमूम् ।
व्यूढां द्रुपदपुत्रेण तव शिष्येण धीमता ॥ १-३॥
अन्ये च बहवः शूरा मदर्थे त्यक्तजीविताः ।
नानाशस्त्रप्रहरणाः सर्वे युद्धविशारदाः ॥ १-९॥
अपर्याप्तं तदस्माकं बलं भीष्माभिरक्षितम् ।
पर्याप्तं त्विदमेतेषां बलं भीमाभिरक्षितम् ॥ १-१०॥
सत्कारमानपूजार्थं तपो दम्भेन चैव यत् ।
क्रियते तदिह प्रोक्तं राजसं चलमध्रुवम् ॥ 17.18॥
hello world
kk
kubhpkn
अभिसन्धाय तु फलं दम्भार्थमपि चैव यत् ।
इज्यते भरतश्रेष्ठ तं यज्ञं विद्धि राजसम् ॥ 17.12॥
अयनेषु च सर्वेषु यथाभागमवस्थिताः ।
भीष्ममेवाभिरक्षन्तु भवन्तः सर्व एव हि ॥ १-११॥
सत्कारमानपूजार्थं तपो दम्भेन चैव यत् ।
क्रियते तदिह प्रोक्तं राजसं चलमध्रुवम् ॥ 17.18॥
सत्कारमानपूजार्थं तपो दम्भेन चैव यत् ।
क्रियते तदिह प्रोक्तं राजसं चलमध्रुवम् ॥ 17.18॥
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)