#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?si)(Test|Hello)\s*([^:]*):\n(\n.*?)(?=Test[^:]*:|Hello[^:]*:|$)"
Local $sString = "Test 123:" & @CRLF & _
"" & @CRLF & _
"This is a blue car" & @CRLF & _
"" & @CRLF & _
"Test:" & @CRLF & _
"" & @CRLF & _
"This car is not blue" & @CRLF & _
"" & @CRLF & _
"This car is yellow" & @CRLF & _
"" & @CRLF & _
"Hello:" & @CRLF & _
"" & @CRLF & _
"This is not a test"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")