$re = '/(Test|Hello)\s*([^:]*):\n(\n.*?)(?=Test[^:]*:|Hello[^:]*:|$)/si';
$str = 'Test 123:
This is a blue car
Test:
This car is not blue
This car is yellow
Hello:
This is not a test';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);