import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(Test|Hello)\\s*([^:]*):\\n(\\n.*?)(?=Test[^:]*:|Hello[^:]*:|$)";
final String string = "Test 123:\n\n"
+ "This is a blue car\n\n"
+ "Test:\n\n"
+ "This car is not blue\n\n"
+ "This car is yellow\n\n"
+ "Hello:\n\n"
+ "This is not a test";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}