const regex = /^(?!(^-|-$|.{24,})).*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!(^-|-$|.{24,})).*', 'gm')
const str = `Winston1-Salem6
Winston-Salem
Winston Salem
1-two3
word2 with space
-Newberty-Los-
12345678901234567890123444
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}