$re = '/^(?!(^-|-$|.{24,})).*/m';
$str = 'Winston1-Salem6
Winston-Salem
Winston Salem
1-two3
word2 with space
-Newberty-Los-
12345678901234567890123444
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);