import re
regex = re.compile(r"^(?!(^-|-$|.{24,})).*", flags=re.MULTILINE)
test_str = ("Winston1-Salem6\n"
"Winston-Salem\n"
"Winston Salem\n"
"1-two3\n"
"word2 with space\n"
"-Newberty-Los-\n"
"12345678901234567890123444\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")