#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "struct_separate_cart\.cart[a-zA-Z0-9\[\.\]\_]+\.shipping\.discount"
Local $sString = "struct_separate_cart.cart[LOCAL.this_vendor].shipping.discount"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")