$re = '/struct_separate_cart\.cart[a-zA-Z0-9\[\.\]\_]+\.shipping\.discount/';
$str = 'struct_separate_cart.cart[LOCAL.this_vendor].shipping.discount';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);