import re
regex = re.compile(r"struct_separate_cart\.cart[a-zA-Z0-9\[\.\]\_]+\.shipping\.discount")
test_str = "struct_separate_cart.cart[LOCAL.this_vendor].shipping.discount"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")