using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<![\w\-]=""|"")(?<![\w\-]=|>)(?<!#|>)(https?:\/\/[\w\-\.!~?&=+\*'(),\/\#\:]+)((?!\<\/\w\>))*?";
string substitution = @"<a href=""$1"">$1</a>";
string input = @"<a href=""https://worldofwarships.ru/"">https://worldofwarships.ru/</a><div><br></div>
<div data-test=""https://worldofwarships.ru/1"">https://worldofwarships.ru/1</div>
<div>!https://worldofwarships.ru/0</div>
<div>https://worldofwarships.ru/0</div>
<div> https://worldofwarships.ru/2</div>
https://worldofwarships.ru/3?test=https://worldofwarships.ru/
https://worldofwarships.ru/4#https://worldofwarships.ru/
https://worldofwarships.ru/5
<div>https://worldofwarships.ru/3<br clear=""all"">
<div><br></div>-- <br><div class=""gmail_signature""><div dir=""ltr"">Тестовый аккаунт</div></div>
</div>
<img src=""https://worldofwarships.ru/3?test=https://worldofwarships.ru/3""/>
<img src=""https://worldofwarships.ru/3#https://worldofwarships.ru/3""/>
<form action=""https://worldofwarships.ru/3""></form>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}