# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<![\w\-]=\"|\")(?<![\w\-]=|>)(?<!#|>)(https?:\/\/[\w\-\.!~?&=+\*'(),\/\#\:]+)((?!\<\/\w\>))*?"
test_str = ("<a href=\"https://worldofwarships.ru/\">https://worldofwarships.ru/</a><div><br></div>\n\n"
"<div data-test=\"https://worldofwarships.ru/1\">https://worldofwarships.ru/1</div>\n\n"
"<div>!https://worldofwarships.ru/0</div>\n\n"
"<div>https://worldofwarships.ru/0</div>\n\n"
"<div> https://worldofwarships.ru/2</div>\n\n"
"https://worldofwarships.ru/3?test=https://worldofwarships.ru/\n\n"
"https://worldofwarships.ru/4#https://worldofwarships.ru/\n\n"
"https://worldofwarships.ru/5\n\n"
"<div>https://worldofwarships.ru/3<br clear=\"all\">\n"
"<div><br></div>-- <br><div class=\"gmail_signature\"><div dir=\"ltr\">Тестовый аккаунт</div></div>\n"
"</div>\n\n"
"<img src=\"https://worldofwarships.ru/3?test=https://worldofwarships.ru/3\"/>\n"
"<img src=\"https://worldofwarships.ru/3#https://worldofwarships.ru/3\"/>\n\n"
"<form action=\"https://worldofwarships.ru/3\"></form>")
subst = "<a href=\"$1\">$1</a>"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.