using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"abc=\K\d+";
string substitution = @"";
string input = @"abc=0;def=2;abc=1;ghi=4;jkl=2";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}