$re = '/abc=\K\d+/m';
$str = 'abc=0;def=2;abc=1;ghi=4;jkl=2';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;