use strict;
my $str = 'abc=0;def=2;abc=1;ghi=4;jkl=2';
my $regex = qr/abc=\K\d+/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";