# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=abc=)\d+//gm;t' <<< "abc=0;def=2;abc=1;ghi=4;jkl=2"