const regex = /(?<=abc=)\d+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=abc=)\\d+', 'gm')
const str = `abc=0;def=2;abc=1;ghi=4;jkl=2`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);