import re
regex = re.compile(r"(?<=abc=)\d+", flags=re.MULTILINE)
test_str = "abc=0;def=2;abc=1;ghi=4;jkl=2"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)