$re = '/\d+(\.\d+)?(?=[a-z])/m';
$str = '-20.4a 110b 139 31c 10.4';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;