import re
regex = re.compile(r"\d+(\.\d+)?(?=[a-z])", flags=re.MULTILINE)
test_str = "-20.4a 110b 139 31c 10.4"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)