re = /\d+(\.\d+)?(?=[a-z])/m
str = '-20.4a 110b 139 31c 10.4'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result