use strict;
my $str = 'I want to capture all colors that are not "transparent", "inherit" or starts with an "@" character.
should be captured
--------------------------
color: blue;
color:red3434;
color: red3434;
color: #00FF00;
color: #F0F;
color: face(@B23);
should not be captured
--------------------------
color: transparent;
color: @transparent;
color: @transparent;
color: inherit;
color: @B23;';
my $regex = qr/^color:(?!\s*@|\s*transparent|\s*inherit).*;$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}