# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^color:(?!\s*@|\s*transparent|\s*inherit).*;$"
test_str = ("I want to capture all colors that are not \"transparent\", \"inherit\" or starts with an \"@\" character.\n\n"
"should be captured\n"
"--------------------------\n"
"color: blue;\n"
"color:red3434;\n"
"color: red3434;\n"
"color: #00FF00;\n"
"color: #F0F;\n"
"color: face(@B23);\n\n"
"should not be captured\n"
"--------------------------\n"
"color: transparent;\n"
"color: @transparent;\n"
"color: @transparent;\n"
"color: inherit;\n"
"color: @B23;")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.