import Foundation
let pattern = #"^color:(?!\s*@|\s*transparent|\s*inherit).*;$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
I want to capture all colors that are not "transparent", "inherit" or starts with an "@" character.
should be captured
--------------------------
color: blue;
color:red3434;
color: red3434;
color: #00FF00;
color: #F0F;
color: face(@B23);
should not be captured
--------------------------
color: transparent;
color: @transparent;
color: @transparent;
color: inherit;
color: @B23;
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)