using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\""msgContentType\""\:\""(?<your_field>java[^\""]*)";
string input = @"""msgContentType"":""Exception occured Retirement Audit Rest service""
""msgContentType"":""java.net.SocketTimeoutException: Read timed out""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}