$re = '/\"msgContentType\"\:\"(?<your_field>java[^\"]*)/';
$str = '"msgContentType":"Exception occured Retirement Audit Rest service"
"msgContentType":"java.net.SocketTimeoutException: Read timed out"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);