package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\"msgContentType\"\:\"(?<your_field>java[^\"]*)`)
var str = `"msgContentType":"Exception occured Retirement Audit Rest service"
"msgContentType":"java.net.SocketTimeoutException: Read timed out"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}