using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^\d{1,2}+\.\d{1,2}\.\d{1,2}\.\d{1,2}$)";
string input = @"qsdf4ghjk dfdf dfd 4fdfd3 d
4444
but not 4444
4444
333
44444.4444
2222
1
2.
3
555
6.6.7
44.5.
4.5.6.
4.5.6.7
44.44.6.4
12.12.12.12
dddd
this is a test of 3.4 and 3.4.5 and 3.4.5.6 and 33.44.55.66
hopefully something is learnded. qsdf4ghjk,
2.4.5.6.7 is here but at the beginning lets's put
2.3.5.7 but not 2.4.6.7. No space 2.4.6.7 .
3.5.6.7.
3.3.3
44
3.3.3.3
4.5.6.7.8 and more";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}