import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?:(?:(?:(?:(?:0[13578])|(?:1[02]))\\/(?:(?:0[1-9])|(?:[1-2][0-9])|(?:3[01])))|(?:(?:(?:0[469])|11)\\/(?:(?:0[1-9])|(?:[1-2][0-9])|30))|(?:02\\/(?:(?:0[1-9])|(?:[1-2][0-9]))))\\/\\d{2}(?:(?:[02468][048])|(?:[13579][26])))|(?:(?:(?:(?:(?:0[13578])|(?:1[02]))\\/(?:(?:0[1-9])|(?:[1-2][0-9])|(?:3[01])))|(?:(?:(?:0[469])|(?:11))\\/(?:(?:0[1-9])|(?:[1-2][0-9])|(?:30)))|(?:02\\/(?:(?:0[1-9])|(?:1[0-9])|(?:2[0-8]))))\\/\\d{2}(?:(?:[02468][1235679])|(?:[13579][01345789]))))(?:\\s(?:(?:(?:0[1-9])|(?:1[0-2]))\\:(?:[0-5][0-9])(?:\\:(?:[0-5][0-9])\\s))(?:AM|PM|am|pm))?$";
final String string = "12/12/2012\n"
+ "12/12/2012 05:05:59 am\n"
+ "02/29/2012\n"
+ "02/29/2010\n"
+ "02/28/2010\n"
+ "12/31/2012 11:59:55 pm\n"
+ "25/12/2019 05:00:00 pm\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}