const regex = /^(?:(?:(?:(?:(?:(?:0[13578])|(?:1[02]))\/(?:(?:0[1-9])|(?:[1-2][0-9])|(?:3[01])))|(?:(?:(?:0[469])|11)\/(?:(?:0[1-9])|(?:[1-2][0-9])|30))|(?:02\/(?:(?:0[1-9])|(?:[1-2][0-9]))))\/\d{2}(?:(?:[02468][048])|(?:[13579][26])))|(?:(?:(?:(?:(?:0[13578])|(?:1[02]))\/(?:(?:0[1-9])|(?:[1-2][0-9])|(?:3[01])))|(?:(?:(?:0[469])|(?:11))\/(?:(?:0[1-9])|(?:[1-2][0-9])|(?:30)))|(?:02\/(?:(?:0[1-9])|(?:1[0-9])|(?:2[0-8]))))\/\d{2}(?:(?:[02468][1235679])|(?:[13579][01345789]))))(?:\s(?:(?:(?:0[1-9])|(?:1[0-2]))\:(?:[0-5][0-9])(?:\:(?:[0-5][0-9])\s))(?:AM|PM|am|pm))?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(?:(?:(?:(?:(?:0[13578])|(?:1[02]))\\\/(?:(?:0[1-9])|(?:[1-2][0-9])|(?:3[01])))|(?:(?:(?:0[469])|11)\\\/(?:(?:0[1-9])|(?:[1-2][0-9])|30))|(?:02\\\/(?:(?:0[1-9])|(?:[1-2][0-9]))))\\\/\\d{2}(?:(?:[02468][048])|(?:[13579][26])))|(?:(?:(?:(?:(?:0[13578])|(?:1[02]))\\\/(?:(?:0[1-9])|(?:[1-2][0-9])|(?:3[01])))|(?:(?:(?:0[469])|(?:11))\\\/(?:(?:0[1-9])|(?:[1-2][0-9])|(?:30)))|(?:02\\\/(?:(?:0[1-9])|(?:1[0-9])|(?:2[0-8]))))\\\/\\d{2}(?:(?:[02468][1235679])|(?:[13579][01345789]))))(?:\\s(?:(?:(?:0[1-9])|(?:1[0-2]))\\:(?:[0-5][0-9])(?:\\:(?:[0-5][0-9])\\s))(?:AM|PM|am|pm))?$', 'gm')
const str = `12/12/2012
12/12/2012 05:05:59 am
02/29/2012
02/29/2010
02/28/2010
12/31/2012 11:59:55 pm
25/12/2019 05:00:00 pm
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}