# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<!\d)(\d{5}(?:[-\s]\d{4})?)\b"
test_str = ("\"Mr. Bean bought 2 tickets 2-613-213-4567\",\n"
" \"43 Butter Rd, Brossard QC K0A 3P0 – 613 213 4567\", \n"
" \"Rat Race, XX, 12345\",\n"
" \"Ignore phone numbers(613)2134567\",\n"
" \"Grab zips with dashes 12345-6789 or no space before12345-6789\", \n"
" \"Grab zips with spaces 12345 6789 or no space before12345 6789\",\n"
" \"I like 1234567 dogs\"")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.