package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(^|\s|>)#([^\s<>]+)\b`)
var str = `https://domain.com/x#fragment
#hashtag
nota#hashtag`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}