re = /(^|\s|>)#([^\s<>]+)\b/
str = 'https://domain.com/x#fragment
#hashtag
nota#hashtag'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end