$re = '/(^|\s|>)#([^\s<>]+)\b/';
$str = 'https://domain.com/x#fragment
#hashtag
nota#hashtag';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);