using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\$\{\$\{([\w-_\[\]]*?)\}\}|\$\{([\w-_\[\]]*?)\}|\$\{(((.*?)\})+)";
string input = @"
${${IP}${hi}${hello}${ab${cd}ef}${CUPM_IP}}
${LAST-NA[M]E}
${[BRACKETS]}
${CP_IM} ${b} ${1} ${} ${LAST-NAM[E]} ${12} ${34}${56} ${[BRACKETS]}
hello test b ${hg ${$} ${hello word} ${12-34_ab%}
${hg ${$}}
${${hi}}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}