import re
regex = re.compile(r"\$\{\$\{([\w-_\[\]]*?)\}\}|\$\{([\w-_\[\]]*?)\}|\$\{(((.*?)\})+)")
test_str = ("\n\n"
"${${IP}${hi}${hello}${ab${cd}ef}${CUPM_IP}}\n"
"${LAST-NA[M]E}\n"
"${[BRACKETS]}\n\n"
"${CP_IM} ${b} ${1} ${} ${LAST-NAM[E]} ${12} ${34}${56} ${[BRACKETS]}\n\n"
" hello test b ${hg ${$} ${hello word} ${12-34_ab%}\n\n"
"${hg ${$}}\n\n"
"${${hi}}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")