#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!\blogin\b|\bregister\b).+"
Local $sString = "test" & @CRLF & _
"help" & @CRLF & _
"123" & @CRLF & _
"testing" & @CRLF & _
"test" & @CRLF & _
"hello" & @CRLF & _
"login" & @CRLF & _
"register" & @CRLF & _
"logins" & @CRLF & _
"registering"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")