re = /^(?!\blogin\b|\bregister\b).+/m
str = 'test
help
123
testing
test
hello
login
register
logins
registering'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end