$re = '/^(?!\blogin\b|\bregister\b).+/m';
$str = 'test
help
123
testing
test
hello
login
register
logins
registering';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);