$re = '/^(/index\.php/Cdiscount/Package/download/type/offers/filename/BMS_PREFIX_)(.+)/BMS_PREFIX_(.+).zip/';
$str = '/index.php/Cdiscount/Package/download/type/offers/filename/BMS_PREFIX_161d529d7c3ef4b5ae1dca92e2334de6/BMS_PREFIX_161d529d7c3ef4b5ae1dca92e2334de6.zip
';
$subst = "$1$2";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;