// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^(/index\.php/Cdiscount/Package/download/type/offers/filename/BMS_PREFIX_)(.+)/BMS_PREFIX_(.+).zip").unwrap();
let string = "/index.php/Cdiscount/Package/download/type/offers/filename/BMS_PREFIX_161d529d7c3ef4b5ae1dca92e2334de6/BMS_PREFIX_161d529d7c3ef4b5ae1dca92e2334de6.zip
";
let substitution = "$1$2";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}