const regex = /\>(.*?)\</ig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\>(.*?)\\<', 'ig')
const str = `<div>PowerEdge R830 </div><div>PowerEdge R830 Server<span class="Apple-tab-span" style="white-space:pre"> </span>PER830<span class="Apple-tab-span" style="white-space:pre"> </span>[210-AIBO] [329-BCZO]<span class="Apple-tab-span" style="white-space:pre"> </span>1</div><div>Hardware Support Services </div><div>3 Years ProSupport Plus Next Business Day Onsite Service<span class="Apple-tab-span" style="white-space:pre"> </span>PPN3<span class="Apple-tab-span" style="white-space:pre"> </span>[810-0421] [810-0503] [810-0517] [951-2015]<span class="Apple-tab-span" style="white-space:pre"> </span>29</div><div>Shipping Information </div><div>US No Canada Ship Charge<span cl`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}