# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\>(.*?)\<"
test_str = "<div>PowerEdge R830 </div><div>PowerEdge R830 Server<span class=\"Apple-tab-span\" style=\"white-space:pre\"> </span>PER830<span class=\"Apple-tab-span\" style=\"white-space:pre\"> </span>[210-AIBO] [329-BCZO]<span class=\"Apple-tab-span\" style=\"white-space:pre\"> </span>1</div><div>Hardware Support Services </div><div>3 Years ProSupport Plus Next Business Day Onsite Service<span class=\"Apple-tab-span\" style=\"white-space:pre\"> </span>PPN3<span class=\"Apple-tab-span\" style=\"white-space:pre\"> </span>[810-0421] [810-0503] [810-0517] [951-2015]<span class=\"Apple-tab-span\" style=\"white-space:pre\"> </span>29</div><div>Shipping Information </div><div>US No Canada Ship Charge<span cl"
matches = re.finditer(regex, test_str, re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.