import Foundation
let pattern = #"\>(.*?)\<"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"<div>PowerEdge R830 </div><div>PowerEdge R830 Server<span class="Apple-tab-span" style="white-space:pre"> </span>PER830<span class="Apple-tab-span" style="white-space:pre"> </span>[210-AIBO] [329-BCZO]<span class="Apple-tab-span" style="white-space:pre"> </span>1</div><div>Hardware Support Services </div><div>3 Years ProSupport Plus Next Business Day Onsite Service<span class="Apple-tab-span" style="white-space:pre"> </span>PPN3<span class="Apple-tab-span" style="white-space:pre"> </span>[810-0421] [810-0503] [810-0517] [951-2015]<span class="Apple-tab-span" style="white-space:pre"> </span>29</div><div>Shipping Information </div><div>US No Canada Ship Charge<span cl"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)