import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b((?!CR|cr)[A-Za-z]{2}\\d{5,6})\\b(?![\\s\\S]*\\b\\1\\b)";
final String string = "CX12345\n"
+ "CX14584\n"
+ "JB145888\n"
+ "JD748452\n"
+ "CX12345\n"
+ "LM45855";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}