re = /\b((?!CR|cr)[A-Za-z]{2}\d{5,6})\b(?![\s\S]*\b\1\b)/
str = 'CX12345
CX14584
JB145888
JD748452
CX12345
LM45855'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end