const regex = /\b((?!CR|cr)[A-Za-z]{2}\d{5,6})\b(?![\s\S]*\b\1\b)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b((?!CR|cr)[A-Za-z]{2}\\d{5,6})\\b(?![\\s\\S]*\\b\\1\\b)', 'g')
const str = `CX12345
CX14584
JB145888
JD748452
CX12345
LM45855`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}