using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<span.*?>\K(.*?)(?=<\/span>)";
string input = @"<span style=""font-size:10.66px;"">e</span><span style=""font-size:10.66px;"">nhancement·for·existing·report</span>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}