re = /<span.*?>\K(.*?)(?=<\/span>)/
str = '<span style="font-size:10.66px;">e</span><span style="font-size:10.66px;">nhancement·for·existing·report</span>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end